Prev / Next / カメ太の日記

20の扉[unplugged][dolittle][infoedu]

2008-11-24

dolittle20q
ドリトルで「20の扉」を作ってみました。アンプラグドでは「学習5 20の
扉(情報理論)」です。プログラムの質問と答えは変更可能です。1行目で配
列を作り、2〜5行目で次のように質問と要素を入れています。例は3段で
す(「3の扉」)。n段目には2^(n-1)個の要素を入れてください
・1,2,4,...のようにn段の質問を入れる。
・最後のn+1段に選択肢を入れる
オンライン版ドリトル(V2)に貼り付けて実行してください。

a=配列!作る。
a!"生き物?" 書く。
a!"乗り物?" "水の中?" 書く。
a!"楽器?" "飛ぶ?" "足は4本?" "足がある?" 書く。
a!"星" "トランペット" "自動車" "ロケット" "かぶと虫" "うさぎ" "さかな" "かめ" 書く。

level=(log((a!要素数?)+1)/log(2))。
n=1。
「
 ラベル!(a!(n)読む)作る。
 時計=タイマー!作る 1000 時間 「」実行。
 yb=ボタン!"Yes"作る。
 yb:動作=「:n=2*:n+1。nb!消える。yb:動作=「」。時計!中断」。
 nb=ボタン!"No"作る。
 nb:動作=「:n=2*:n。yb!消える。nb:動作=「」。時計!中断」。
 時計!待つ。
 ラベル!作る 次の行。
」!(level-1)繰り返す。
ラベル!作る 次の行。
ラベル!(a!(n)読む)作る。



「20の扉」はおもちゃが売られているのですね。オンラインのデモ版を教えて
もらいました。
20Q

permlink