Prev / Next / カメ太の日記

ゆっくり歩く[dolittle]

2008-11-27

slowwalk
ドリトルのタートルは、カメなのに「カメ太!200歩 歩く」と命令すると
一瞬で200歩歩いてしまいます。タイマーを使って、「ゆっくり歩く」とい
う命令を定義してみました。三角形や星などを描かせてみると、カメ太が
一生懸命描いている様子が見られて楽しいです。

これはドリトルの標準命令に加えてもいいかもしれませんね。名前はどう
しましょう。すでに「歩く」を使っていますので、今回は「ゆっくり歩く」
にしてみました。

カメ太=タートル!作る。
カメ太:ゆっくり歩く=「|歩数| 歩幅=10。タイマー!作る (歩数/歩幅) 回数「カメ太!(歩幅) 歩く」実行 待つ。カメ太」。
「カメ太!100 ゆっくり歩く 144 右回り」!5 繰り返す。


permlink