Prev / Next / カメ太の日記

アニメーションのサンプル[dolittle]

2008-12-07

anime1s

ドリトルでアニメーションプログラムを作るための簡単なサンプルです。
大学の授業用に作りました。

・図形オブジェクト(家と屋根)を動かす
・タートルオブジェクト(3個の花)を動かす
・ひとつの動きが終ってから次を動かす
・オブジェクトを消す
・背景を塗る

// 0.主役を作る
カメ太=タートル!作る。

// 1.家を描く
// (「屋根」の図形オブジェクトを作る)
「カメ太!100 歩く 120 左回り」!3 繰り返す。
屋根=カメ太!(赤)図形を作る。

// (「家」の図形オブジェクトを作る)
「カメ太!100 歩く 90 右回り」!4 繰り返す。
家=カメ太!(緑)図形を作る。

// (家と屋根を動かす)
時計=タイマー!作る「屋根!2 0 移動する。家!2 0 移動する」実行。

// 2.花を作り動かす
花1=カメ太!作る "tulip.png" 変身する ペンなし。
花2=カメ太!作る "tulip.png" 変身する ペンなし。
花3=カメ太!作る "tulip.png" 変身する ペンなし。

// (同じタイマーを使うと、「待つ」を書かなくても前の「実行」が終ってから実行される)
時計!8秒 時間。
時計!「花1!1 -1 移動する。花2!2 -1 移動する。花3!3 -2 移動する。」実行。


// 3.画面クリア
// (5秒後に3個の花を消して背景色を変える)
時計!5秒 間隔 1 回数「
  花1!消える。花2!消える。花3!消える。
  画面!(色!128 128 255 作る)塗る。
」実行。

permlink