Prev / Next / カメ太の日記

授業でチャットプログラム[dolittle][infoedu]

2008-12-19

12/5の都高情研で高校の先生方に体験してもらいましたが、ドリトルでは
生徒のパソコンの間でメッセージを交換するプログラムを簡単に作れます。
詳しくはドリトル本の11章をお読みください。授業で活用する方法につい
ては、改めて解説したいと考えています。

chat

サーバー!"localhost" 接続。
名前="カメ太"。

サーバー!"msg" "" 書く。
メッセージ=フィールド!作る 200 45 大きさ −250 200 位置。
フィールド:動作=「
  サーバー!"msg" (名前!": " (メッセージ!読む)連結)書く。
  メッセージ!クリア。
」。

受信表示=リスト!作る 200 400 大きさ 0 200 位置。
直前メッセージ=""。
タイマー!作る 1 間隔 600 回数「
  受信メッセージ=サーバー!"msg" 読む。
  「受信メッセージ!=直前メッセージ」!なら「受信表示!(受信メッセージ)書く」実行。
  直前メッセージ=受信メッセージ。
」実行。

permlink