Prev / Next / カメ太の日記

得点のカウントダウン[dolittle]

2009-01-12

countdown

ポイントをカウントダウンしていき、0点になったら終了するプログラム例です。

// 得点のカウントダウン。
// 得点フィールドに「加算」という命令を定義している。
// 衝突したときに得点を減算する。0点になるとメッセージを出して終了する。

得点=フィールド!作る 10 書く 0 100 位置(水色)塗る。
得点:カウント=「自分!((自分!読む)−1)書く。「(得点!読む)<=0」!なら「ラベル!"終了"作る。時計!中断」実行」。

「|n| タートル!作る ペンなし "tulip.png" 変身する(n * 45 - 350)0 位置」!15 繰り返す。

かめた=タートル!作る ペンなし -370 0 位置。
かめた:衝突=「|相手| 相手!消える。得点!カウント」。
時計=タイマー!作る「かめた!10 歩く」実行。

permlink