Prev / Next / カメ太の日記

増殖シミュレーション[dolittle]

2009-01-31

life

オブジェクト同士が衝突したときに分裂するシミュレーションです。
・緑色と黄色がいる
・成熟するまでは何も起きない
・衝突すると3個が誕生し、元の2個は消滅する
・寿命が来ると消える

ほとんどの場合はすぐに全滅しますが、10回に1回くらい増殖します。

// パラメータ
成熟=16。
寿命=50。

// すべてのカメの性質を定義 (1:メス、2:オス)
タートル:誕生=「
  年齢=1。性別=乱数(2)。
  「性別==1」!なら「自分!"ayumiKiiro.gif" 変身する」そうでなければ「自分!"ayumi.gif" 変身する」実行。
  時計=タイマー!作る「自分!動く 成長」実行。
」。
タートル:動く=「自分!(乱数(180)-90)右回り 10 歩く」。
タートル:成長=「
  年齢=年齢+1。
  「年齢>=:寿命」!なら「自分!消滅」実行
」。
タートル:消滅=「時計!中断。自分!消える」。
タートル:衝突=「|相手|
  「全部!(性別==1)(相手:性別!=性別)(相手:年齢>=:成熟)(年齢>=:成熟)本当」!なら「
    自分!作る 誕生。自分!作る 誕生。自分!作る 誕生。
    自分!消滅。相手!消滅。
  」実行。
」。
タートル!ペンなし。

// 最初の10匹
タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。
タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。


permlink