カメ太の日記 / 2009-01-31

前の日 / 次の日 / 最新 / 2009-01

01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31

2009-01-31 Sat

増殖シミュレーション [dolittle]

life

オブジェクト同士が衝突したときに分裂するシミュレーションです。
・緑色と黄色がいる
・成熟するまでは何も起きない
・衝突すると3個が誕生し、元の2個は消滅する
・寿命が来ると消える

ほとんどの場合はすぐに全滅しますが、10回に1回くらい増殖します。

// パラメータ
成熟=16。
寿命=50。

// すべてのカメの性質を定義 (1:メス、2:オス)
タートル:誕生=「
  年齢=1。性別=乱数(2)。
  「性別==1」!なら「自分!"ayumiKiiro.gif" 変身する」そうでなければ「自分!"ayumi.gif" 変身する」実行。
  時計=タイマー!作る「自分!動く 成長」実行。
」。
タートル:動く=「自分!(乱数(180)-90)右回り 10 歩く」。
タートル:成長=「
  年齢=年齢+1。
  「年齢>=:寿命」!なら「自分!消滅」実行
」。
タートル:消滅=「時計!中断。自分!消える」。
タートル:衝突=「|相手|
  「全部!(性別==1)(相手:性別!=性別)(相手:年齢>=:成熟)(年齢>=:成熟)本当」!なら「
    自分!作る 誕生。自分!作る 誕生。自分!作る 誕生。
    自分!消滅。相手!消滅。
  」実行。
」。
タートル!ペンなし。

// 最初の10匹
タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。
タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。タートル!作る 誕生。


ドリトル掲示板 [dolittle]

掲示板を作りました。お気軽に質問などを書き込んでください。

2012 : 01 02 03 04 05 06 07 08 09 10 11 12
2011 : 01 02 03 04 05 06 07 08 09 10 11 12
2010 : 01 02 03 04 05 06 07 08 09 10 11 12
2009 : 01 02 03 04 05 06 07 08 09 10 11 12
2008 : 01 02 03 04 05 06 07 08 09 10 11 12
2007 : 01 02 03 04 05 06 07 08 09 10 11 12

最終更新時間: 2012-08-19 23:58

RSS