Prev / Next / カメ太の日記

スモールステップの重要性[dolittle][infoedu]

2009-02-16

プログラムを教える場合には、そこに含まれる概念を分析しておくことは
重要です。ドリトルの場合には、生徒にとって知らない英単語や、身近で
ない記号(「{」や「;」など)を使わないことで余計な敷居は低いのですが、
逆に、生徒は早い段階から「プログラムを作る」という本質的な考え方に
取り組むことになります。

たとえばタートルを作る

カメ太=タートル!作る。

という1行だけを見ても、生徒は
・「タートル」というオブジェクトの種類。
・「!」によるオブジェクトの指定。
・「作る」という命令の送信。
・「作る」の実行によるオブジェクトの生成。
・「。」による文の区切り。
・「カメ太」という変数の概念。
・「=」による変数への代入。
という、数多くの新しい概念を理解することになります。

これらを言葉だけで伝えることは無理がありますので、授業では

カメ太=タートル!作る。
カメ太!100 歩く。

といったレベルの簡単なプログラムを題材に、
・意味を説明し
・少しずつ値を変えながら何度も実行させる
ということを繰り返しながら、最初は1時間くらいかけて、頭の中に「なる
ほど、プログラムはこうやって書けばいいのか」というモデルを作って行
きます。

言い換えると、生徒に対しては、

カメ太=タートル!作る。
カメ太!100 歩く。

というプログラムを示して「カメの作り方と動かし方を勉強しよう」と大
まかに説明するわけですが、先生自身が大まかな理解のままでは授業を作
れません。この2行を教えるために、先ほど書いたような、数多くの理解の
ステップに分解し、できるだけ「いちどに1個のステップごと」の形で進め
ることが必要です。

permlink