Prev / Next / カメ太の日記

画像を切り替えながら移動[dolittle]

2009-07-07

ある方から「口をぱくぱくしながら動くパックマンのように、2つの画像を
切り替えながら移動したい」という質問をいただきました。タイマーは現
在が何回目の実行かをパラメータで受け取れます。回数が偶数か奇数かで
画像を切り替えると、お望みの動作になりそうです。

こういう、小さなTipsはどこかにまとめておきたいですね。

かめた=タートル!作る。
時計=タイマー!作る 0.5 間隔「|n|
 「n%2==0」!なら「かめた!"ayumi.png"変身する」そうでなければ「かめた!"ayumiBlue.png"変身する」実行。
 かめた!10 歩く。
」実行。

permlink