Prev / Next / カメ太の日記

バーコードチェックプログラム[dolittle]

2011-07-08

注文していたバーコードリーダーが届きました。高機能のものが3千円台で
入手できるんですね。USB接続で、キーボードからのように入力されます。
WindowsとMacで動作を確認しました。
便利だったのは、設定でチェックディジットをはずせること。意図的に
間違ったバーコードを読ませる実習に使えそうです。
エフケイシステム CCDバーコードリーダー USBインターフェイス TSK-U

バーコードの作成は、印刷できるサイトを使いました。便利です。

・「バーコードの作成と印刷」。使いやすいです。意図的にチェック
デジットが間違ったバーコードを作ることはできないようでした。
http://www5d.biglobe.ne.jp/~bar/page3/barmain.html

・「無料バーコード作成ツール」。こちらは間違ったものもOKでした。
http://rs-lab.net/jancode/

ドリトルでバーコードを読んで表示するプログラムを書いてみました。
チェックディジットの計算をして、エラーがあれば表示します。文房具や
本の商品情報を登録しておくと、バーコードを読んだときに、商品名が表
示されます。

このような小さなツールを用意することで、情報システムの授業で活用す
ることができそうです。

dbarcode

ラベル!"        バーコードチェックプログラム"作る(青)文字の色。
バーコード=フィールド!"" 作る 次の行。
結果=リスト!作る 400 400 大きさ。
バーコード:動作=「
  barcode=バーコード!読む。
  codes=barcode!"" 分割。
  codes!1 位置で消す。
  codesize=codes!要素数?。

  s=0。
  「|n|
   c=codes!(n)読む。
   s=s+c。「(n%2)==0」!なら「s=s+c*2」実行。
  」!(codesize)繰り返す。
  cd=s%10。
  cd12=0。「codesize==13」!なら「cd12=(s-(codes!13 読む))%10」実行。

  「cd==0」!なら「
    結果!(""!(barcode)"("(!(barcode)lookup)")"連結)書く。
  」そうでなければ「
    結果!("エラー:"!(barcode)"の正しいチェックディジットは"(10-cd12)"です。"連結)書く。
  」実行。
  バーコード!クリア。
」。
バーコード:lookup=「|code|
  ret=""。
  「|n| 「(商品!(n)読む)==code」!なら「ret=商品!(n+1)読む」実行」!(商品!要素数?)繰り返す。
  ret。
」。
商品=配列!
"9784904013083" "ドリトルで学ぶプログラミング"
"4901620303167" "バターサブレ"
"4902471030080" "キレートレモン"
"4901991650167" "スティックのり"
作る。

permlink